Mission Files

NAK Servers Feedback Report

Moderator: VileAce

Post Reply
Posts: 9
Joined: August 4th, 2018, 9:19 am

May 12th, 2019, 10:53 am

Hi all,

I just wanted to post this to help anyone else that has this issue.

For the last two days I couldn't get on Altis server because the 20,797KB file mission file would not download. The progress bar goes about 3/4 of the way (13882/20797KB) then halts, and after about 60 seconds I get the message "Connection to host has been lost." I was playing on Altis earlier last week with no problems, but the mission file was apparently updated and now I can't get it to go.
Consecutive attempts usually produce "Connecting Failed" message until I restart Arma 3. Friday night I tried a few times, then went over to Tanoa and it did the same thing, stopped downloading at 14223/17286KB. So I went over to Malden it worked so I invited my friends over there and we had a grand old time. But I noted that sometime later Friday night, after the Tanoa server reset that evening I think, I was able to fully download the Tanoa mission file. So I waited for an Altis server reset and it still failed to download. Grrrrr. Tried again a few time Saturday, and again this morning - file won't download. Malden had given me no issues yet, I assume the mission file was not updated last week. This happened last week or maybe the week before with Tanoa too, but it eventually went. Altis ping is around 100ms, most days it is in the low 90s it but sometimes up to about 110ms. My Internet connection is >100Mbps so it is not a slow Internet problem. I have about 60GB of free space on my SSD and system disk has about 50GB free so I don't believe it to be a drive space problem.

I tried:
A fresh reboot of the PC
Validating local game files
Entering with no mods loaded
Waiting for server reset
Surfing the Internets for clues
Removing a few more hairs from my preciously coiffed scalp
Drinking a few beers

What worked finally: Deleted the file "I_&_A_Updat.Altis.pbo" from folder "C:\Users\<my location>\AppData\Local\Arma 3\MPMissionsCache" to force a new download. It finished downloading on the first try after that.

J. Elkroc

User avatar
Site Admin
Posts: 1547
Joined: April 6th, 2017, 1:00 pm
Location: North Carolina

NAK Command


NAK Elite

NAK Donor

May 12th, 2019, 12:48 pm

This is a known issue, specifically if you have internet issues in general. To find the location of your MPMissionsCache files (it will vary between computers), in File Explorer, in the address bar type "%localappdata%/Arma 3/MPMissionsCache" without quotes. You may delete all files in this directory. This will force Arma to redownload the mission files when you connect to a server again. The reason it is better to delete all files, rather than a specific file, is we do change our mission name on a regular basis, by deleting all of them you are sure to get the correct file. The only negative of deleting all files is you may have to redownload a mission file again that did not need to be updated, which should take around 30 seconds.

Be aware that this is a different issue from Steam Connection Failed or Steam authentication failed. Thought for the latter, clearing the MPMissionsCache is part of the steps to try and resolve the issue.

Posts: 9
Joined: August 4th, 2018, 9:19 am

May 12th, 2019, 2:08 pm

Thanks Vile. Yeah, in my hunting, I never ran across a post that said to delete the file but it is something that occurred to me from my computer work. Next time I may delete all the files in the folder. There is a boatload of them and I only play NAK servers these days, so no need for them.

Posts: 9
Joined: August 4th, 2018, 9:19 am

May 16th, 2019, 6:39 pm

It happened again. Upon further study, I found that after my recent router upgrade, I forgot to forward Arma 3 ports. All servers work now. This will happen again, that is why I leave breadcrumbs like this around the innernets, to find my way again.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users